Wiki Page Content

Aggiornare Python

Se si desidera cambiare la versione di Python che esegue MoinMoin è necessario prendere in considerazione alcuni problemi:

Posizione della directory di MoinMoin

Il processo di installazione (setup.py) installa i file di MoinMoin nella directory site-packages dell'installazione attuale di Python (per esempio /usr/lib/python2.4/site-packages). Se si passa a un altro interprete Python è necessario reinstallare i file di MoinMoin nella nuova directory /usr/lib/pythonX.X/site-packages. Se MoinMoin è stato installato in una posizione diversa ed è stato modificato sys.path questo non è un problema.

I file precompilati di Python (.pyc)

Python non garantisce che i file .pyc siano compatibili tra le versioni di Python. Se viene modificato l'interprete di Python è necessario ricompilare gli script di Python. È possibile usare:

python -c "import compileall; compileall.compile_dir('/percorso/a/MoinMoin')"

Se viene reinstallato MoinMoin dopo il nuovo inteprete questo passo non è richiesto/fatto da setup.py.

Svuotare la cache della pagina

La cache usa byte code di Python per creare le pagine più velocemente. Per evitare problemi di compatibilità è necessario svuotarla a mano cancellando tutti i file in data/pages/*/cache/ e underlay/pages/*/cache/.

Feedback
Please include your contact information if you'd like to receive a reply.
Submit